MatMagic User’s Guide
Introduction

MatMagic is a software application that allows you to organize and generate team, bracket and bout sheets for Youth Wrestling Tournaments. The software allows you to define how many sessions and mats your tournament will have. It will then let you associate what wrestler birth-years will be wrestling at which session.  You can also enter team/club information including name and abbreviation of the team and the complete wrestling roster for the team. The Team view allows you to enter the name, weight, and years of experience for each wrestler. The Team view also allows you to directly import a team roster directly from an Excel spreadsheet.
Once all the team information is entered you may generate brackets automatically. The MatMagic software will bracket wrestlers based on Age, weight (less than 10% per bracket), and team diversity.  MatMagic tries to avoid putting more than one wrestler per team in a bracket so that kids do not end up wrestling kids they practice with day in and day out.  Once brackets have been auto-generated they must be reviewed and fine tuned by hand.  It is possible that some kids will end up in 1-man brackets which means there are no other wrestlers that match the bracketing criteria.  You will have to make decisions as to what criteria (Age/Weight/Team diversity) you want to relax in order to let the wrestler be able to compete in your tournament.  This relaxing of criteria must be done manually placing the wrestler into a bracket using the Bracket Form View.
Once you are satisfied that the brackets are complete and correct, you can automatically allocate the brackets to the mats.  MatMagic calculates how many matches each bracket will have based on the number of wrestlers and type of bracket.  The auto-allocation makes sure that each mat has the same number of matches not brackets to wrestle.  Again, you should double-check and fine tune the assignment of brackets to mats using the Bracket Form View.

Once you are satisfied with the brackets and mat assignments for each session in your tournament you are ready to print your sheets. You can print team,bracket or bout sheets individually or in complete sets.  First, you can print all your team sheets that contain information about what mat, bracket, and session each wrestler is in.  Next you can print all the bracket sheets with out the bout sheets for display on site at your tournament.  Finally, you can print the bracket sheets with the bout sheets for use by table works at the mats in your tournament.  The round robin bracket sheets will be fully populated while the eight man double elimination bracket sheets will have the first four matches populated.
Installation

Simply unzip (extract) all the files from the matmagic.zip file to a local folder on your computer’s hard drive.    To run and launch the matmagic application navigate to the folder you extracted matmagic and double click on the matmagic.exe file.  First a small splash screen comes up.
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Then the entire MatMagic application launches and runs.  The Main Window should look like this
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You are now ready to begin entering your tournaments information.

Window Layout

The MatMagic layout consists of a main menu bar along the top with toolbar underneath. From the main menubar and toolbar you can access functionality for Opening/Saving the state of tournament application.  You can also access all the print all functionality as well bracket generation and mat allocation functionality under the tools menu.

Besides the main menubar/toolbars you have two main view areas.  The left hand side you have a navigation tree view where you navigate and select items (teams,brackets,etc.) as well as access context menus via the right mouse button. In the navigation tree you will find a hierarchical representation of the tournament broken up between teams and brackets.  Both Teams and Brackets will have wrestlers underneath.

On the right hand side you will find five different types of views. Each view is accessed via a tab on the tab bar on top of the right hand side.  All the views but the tournament view will respond and show different contents based on what is currently selected in left hand side navigation tree.  Each view allows you to see a different side of the tournament and allows you to accomplish different tasks.

Tournament View [image: image3.png]


 allows you to see the overall tournament information like the 

number of sessions, number of mats, or birth years association with a session.

Team View [image: image4.png]


 allows you to see all the wrestlers and the information about a wrester
 for a given team.  This is where you enter and edit the team’s roster.


Bracket Form [image: image5.png]


View allows you to see and edit the wrestlers in a given bracket as

well as what mat is bracket is associated.


Bracket Viewer [image: image6.png]


 is graphical view only view that gives a graphical pre-view of what 
bracket sheet will look like for a selected bracket.

Bout Sheet View [image: image7.png]



is also a graphical view only view that gives a graphical pre view of 

what the bout sheet will look like for a selected bracket.
Entering your tournament information

From the Tournament Form View or “Tournament Form Editor” you enter the following information:

Title:  The title of your tournament which will show up on all your bracket sheets

Number of Mats: The number of mats that will be in your tournament

Number of Sessions: The number of different sessions. You would enter 2 for an AM/PM session. You must have at least 1 session.
Min. Birth Year:  This is the oldest birth year you will allow to wrestle at your tournament

Max. Birth Year: This is the youngest birth year you will allow to wrestle at your tournament.

Max. Bracket Type: Valid options are 4-Man Round Robin or 8-Man double elimination. Sometimes when you are having a very small tournament it is easier to just make all the brackets 4-Man round robin brackets rather than have sparsely populated 8-man double elimination brackets. By selecting 4-Man the auto-generate will make sure that the largest bracket generated will be 4 man round robin.
Auto Bracket by: Valid options are Birth Year or Age Group. If Birth Year is selected then all generated brackets will be separated based on the wrestlers birth year.  If Age Group is selected then all generated brackets will be separated based on the wrestlers Age Group.
Number of Age Groups: This field is only enabled when Auto Bracket by Age Group is selected. The field will defines the number of age groups or divisions your tournament is supporting.

Bracket first year wrestlers separate?: If this field is selected then wrestlers whose experience is 0 years will be put in separate brackets if there are at least 4 wrestlers in appropriate weight and age to form a bracket.  Otherwise first year wrestlers are bracketed with all the other wrestlers for his birth year/age group.
The Birth year to session and age group Mapping section of the Tournament Form View will allow to say what session a given birth year will be wrestling in.  
By default all the birth years are assigned to the first session and first age group.  You may edit the session value and age group value for a given birth year by selecting it a drop down combo-box allows you to select which session or age group the birth year should wrestle in.  Every-time you adjust the number of sessions or the Min/Max birth years you may have to re-map you birth year to session table.  It is critical that this table is complete and correct before you auto generate and allocate brackets to mats.

Team View
You get to the team view, by selecting the team tab in right hand side of views. Your MatMagic application should look like this:
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In the case of a new tournament you have no teams and will need to create them. To create a new team, select Team Command [image: image9.png]


 from the File->New pulldown menu from the main menu bar.  This will create a new team which you must select in the left hand side navigation view.  The team view has three specific commands which can be accessed from the upper right hand side of the view.  Those commands are New Wrestler [image: image10.png]


, Delete Wrestler [image: image11.png]


, and Print Team  [image: image12.png]


view.  
The New wrestler command brings up the New Wrestler dialog that allows you enter in the teams roster. 
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Once you have entered in all the valid information for a single wrestler the Add button will become enabled. Select the add button to create the wrestler in the team. The dialog will not go away until you hit the done command.  This allows you to enter multiple wrestlers in at a time with out re-keying all the same information over and over again.

You can import a whole single team roster from an MS Excel spreadsheet. Please make sure you have already created a Team via the New Team command [image: image14.png]


 and have selected the team in the Left hand Tree View.  Simply select the Import From Excel button from the Team view This will bring up a File Selection Dialog. Please navigate to the Excel Spreadsheet file containing the team roster.  The Import From Excel feature will only import a single team roster at a time. The Team roster must be in the following format.
Starting in Cell A1, the first row should contain the titles “Last Name”, “First Name”, “Birth Year”, “Weight” and “Experience”.  The first row of actual team data should begin in Cell A2.  There should not be any blank rows.  The birth year should NOT be a full date like Jan-19-2000, but rather be a single integer year like 2000. Below is an example Excel Spreadsheet that could be imported into MatMagic.
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You can delete wrestlers from the team by selecting them in the team view table and then hitting the delete wrestler command[image: image16.png]


.  This will delete the wrestler from the tournament and will remove him from the bracket he may be in.

The print team view allows you to print a single team roster.  It is highly recommended that you print team rosters in portrait mode on your printer.

It is highly recommended that you save the state of your tournament often by invoking the save command [image: image17.png]


 from the main menu bar, File->Save.

Generating Brackets

Once all the team rosters for your tournament are entered and complete you are ready to generate automatic brackets. You invoke this command from main menu bar, Tools->Generate Brackets [image: image18.png]


. This command will automatically create brackets based on the following criteria:
1. Only wrestlers of the same birth year will be placed in the same bracket

2. Only wrestlers  who are within 10% or 5 lbs (which ever is more) will be placed in the same bracket

3. A very strong attempt to minimize multiple wrestlers from the same team in a given bracket

4. Fill eight man brackets if possible. Unless you have selected the 4 man bracket type in Tournament Form Editor [image: image19.png]



Important: You must review and fine tune brackets that are automatically generated.

The automatic generation gives you good starting point for your tournament brackets, but you must review and fine tune brackets.  You will find out that some wrestlers will end up in one man brackets thus effectively eliminating them from the tournament. You must find suitable brackets for those wrestlers and place them into those brackets manually.  You may find you have several 5 man brackets which is another bad combination. By relaxing the criteria either on weight or multiple wrestlers for a given team you may be able to fill the bracket.  The relaxing of criteria to modify the brackets must be done manually.  You may find out that you do not have enough wrestlers for given age group to yield acceptable brackets and my want to combine birth years.  I would suggest going back to the team view and modifying the wrestler’s actual birth year to be the birth year that he will wrestle in.  When combining birth years, be careful not to cross tournament session boundaries or kids may come to the wrong session.  Once you have adjusted the birth years on the wrestlers you can re-run the Generate Brackets command.
Warning: Every time you re-run the generate brackets command [image: image20.png]


 any manual edits to the bracket including mat assignments will be lost.  So once you have made significant manual edits that you do not want to redo, do not run the Generate Brackets command again.

You can view brackets from with in the Bracket Viewer [image: image21.png]


 .

Bracket View
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The bracket view allows you to visually inspect what the bracket sheets will look like. In order to modify the bracket sheets you must use the Bracket Form Editor [image: image23.png]


.

Bracket Form Editor

The bracket form editor [image: image24.png]


 allows you to modify several aspects of a given Bracket.
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The bracket overview section gives overview information about the bracket and allows you to manually modify what mat and session the bracket is assigned to. I highly recommend you use the automatic mat assignment command [image: image26.png]e,



 for that activity, but wait until all your brackets are set.

The bracket slots section allows you to add or remove wrestlers to this bracket.  When remove a wrestler from a bracket it does NOT remove him from his tournament or team he is simply un-assigned.  The Add… command will not be enabled unless the bracket is not full.  If your bracket is full then you must remove wrestlers from the bracket before you can add them.  The Add… command  brings up the “Add Wrestler” dialog.
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Only wrestlers that are un-assigned or assigned to one man brackets will be visible in this dialog.  So if you want to add a wrestler from another bracket you must first remove him from the bracket he is currently in.  To easier select wrestlers you may sort the table by clicking on the column header.
You may change the individual match pairing by selecting a wrestler in the Bracket Slots table and then using the Up [image: image28.png]


 or Down  [image: image29.png]


command to move the wrestler up or down.  Use the bracket view to confirm you have achieved the desired initial match pairs.

You can add brand new empty brackets  by selecting File->New->Bracket [image: image30.png]


 from the main menu bar.  You may delete existing brackets by selecting a bracket in the Navigation Tree view and bringing up the brackets context menu via the right mouse button and selecting the Remove Bracket  [image: image31.png]


 command.

Auto Assigning Brackets to Mats

Once you have all your brackets filled out correctly.  You can auto allocation the brackets to mats by selecting the Auto Allocate Mats command from the Tools->Auto Allocate Mats [image: image32.png]e,



 pulldown menu. Depending on how many wrestlers are in a given bracket there will be a fixed number of matches associated with a bracket.  The auto allocate will attempt to evenly distribute the matches to each mat while also attempting to keep kids together by age and weight.  This will help ensure an optimal running of the tournament.  However mat assignments’ can be fine tuned in the Bracket Form View Editor [image: image33.png]


 by in the overview section of  the Bracket Form Editor.
Warning: Every time you re-run the auto allocate mats command [image: image34.png]e,



 any manual edits to the bracket’s mat assignments will be lost.

Bout Sheet View

The Bout Sheet View [image: image35.png]


 will allow you to visually see the bout sheets for the generated bracket.  First select a bracket in the left hand tree, then select Bout Sheet View. Bout Sheets will be fully filled out for round robin brackets. Double Elimination Brackets will have the first round filled out.
Printing Your Tournament
The team, bracket, and bout views all allow you to print individual sheets out at a time.  However, the real power comes when you print all of your tournament sheets at a single time.

It is highly recommended that you print team sheets in portrait mode and print bracket/bout sheets in landscape mode.

You can print your tournament sheets out in three sets which are accessed from the main menu bar: File->Print All

· Teams, this will print all the team rosters including bracket, mat, session assignment. These sheets can be handed out to the Team’s coach upon tournament day registration.  Believe me, coaches really appreciate knowing the bracket number and mat assignment for all their wrestlers.
· Brackets, this will print all the bracket sheets out which could be used for wall display at the tournament.  (Please remember to select landscape mode in your printer preferences). Also you may want to use different color paper for the different sessions.
· Brackets and Bout Sheets, this will print the bracket sheets and bout sheets suitable for use by mat table workers at your tournament.  The bout sheets will fully filled out for all round-robin brackets and partially (first round) filled out for eight man double elimination brackets. An extra blank bout sheet will be printed out for each double elimination bracket.  (Please remember to select landscape mode in your printer preferences)
Whole Tournament Import From an Excel Spreadsheet
There is a special feature to enable the import a whole tournament from a single Excel and generate both teams and wrestlers. This is especially useful, when the rosters have already been combined such as the City Tournament.  To use this feature, go to the File Pulldown from the main menu and select “Import From Excel…”. This will bring up a file selection dialog that allows you to navigate to the Excel file.  
The Excel file must have the data in following format Starting in Column “A”: Last Name, First Name, Year of Birth, Team, Region, Weight, Years of Experience.  The region column will be ignored but must be there and be non blank integer value. The Years of Experience column is optional and may be omitted.  The first row in the spreadsheet will be assumed to contain column titles and thus skipped.  See the example whole_tournament.xls that comes with the zip install for details. 
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Tournament Master Control Spreadsheet Export

Sometimes it is useful to have a single master control spreadsheet at the head table during a tournament to deal with ad-hoc queries and  issues.  The Tournament Master Control spreadsheet lists all the wrestlers with their team, birth year, weight, bracket and mat assignment information. 
You can do this by selecting "Export Master Spreadsheet" from the File pulldown menu off the main menu bar.  This command will then prompt you to provide file name and location to save your Tournament Master Control file.  The file exported will actually be a Comma Separated file, also known as a CSV file.  Most spreadsheet applications including Microsoft Excel will automatically read in CSV formatted files. Once imported into a spreadsheet application like Excel it can be easily sorted for any desired purpose.
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Known Issues
Sometimes the right hand side views do not reflect what is currently selected in the left hand navigation tree.  If this ever happens simply reselect the item in left hand navigation tree until the right hand side view updates correctly.
